summaryrefslogtreecommitdiff
path: root/json-c/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'json-c/configure.in')
-rw-r--r--json-c/configure.in33
1 files changed, 33 insertions, 0 deletions
diff --git a/json-c/configure.in b/json-c/configure.in
new file mode 100644
index 0000000..f0a7d3a
--- /dev/null
+++ b/json-c/configure.in
@@ -0,0 +1,33 @@
+AC_PREREQ(2.52)
+
+# Process this file with autoconf to produce a configure script.
+AC_INIT([JSON C Library], 0.3, [michael@metaparadigm.com], [json-c])
+
+AM_INIT_AUTOMAKE(AC_PACKAGE_NAME, AC_PACKAGE_VERSION)
+
+# Checks for programs.
+
+# Checks for libraries.
+
+# Checks for header files.
+AM_CONFIG_HEADER(config.h)
+AC_HEADER_STDC
+AC_CHECK_HEADERS(fcntl.h limits.h strings.h syslog.h unistd.h [sys/param.h] stdarg.h)
+
+# Checks for typedefs, structures, and compiler characteristics.
+AC_C_CONST
+AC_TYPE_SIZE_T
+
+# Checks for library functions.
+AC_FUNC_VPRINTF
+AC_FUNC_MEMCMP
+AC_FUNC_MALLOC
+AC_FUNC_REALLOC
+AC_CHECK_FUNCS(strndup strerror vsnprintf vasprintf open vsyslog strncasecmp)
+
+AM_PROG_LIBTOOL
+
+AC_OUTPUT([
+Makefile
+json.pc
+])