summaryrefslogtreecommitdiff
path: root/patches
diff options
context:
space:
mode:
authorVincent Sanders <vince@kyllikki.org>2016-10-04 22:14:16 +0100
committerVincent Sanders <vince@kyllikki.org>2016-10-04 22:14:16 +0100
commit9c1b08a7482b5bf164b943e8e4f82c0878f96d60 (patch)
treea6327141eaa0a30df27fdb1f414537d101035ef1 /patches
parentad504b590a7a5014f8801281c7d57ff71535359f (diff)
downloaddebian-9c1b08a7482b5bf164b943e8e4f82c0878f96d60.tar.gz
debian-9c1b08a7482b5bf164b943e8e4f82c0878f96d60.tar.bz2
update for 3.6 release branch
Diffstat (limited to 'patches')
-rw-r--r--patches/change-install-binary-targets8
-rw-r--r--patches/libpng16-fix.patch24
-rw-r--r--patches/series1
3 files changed, 4 insertions, 29 deletions
diff --git a/patches/change-install-binary-targets b/patches/change-install-binary-targets
index 9e1a7fd..e10ebef 100644
--- a/patches/change-install-binary-targets
+++ b/patches/change-install-binary-targets
@@ -1,5 +1,5 @@
---- a/netsurf/framebuffer/Makefile.target
-+++ b/netsurf/framebuffer/Makefile.target
+--- a/netsurf/frontends/framebuffer/Makefile.target
++++ b/netsurf/frontends/framebuffer/Makefile.target
@@ -191,7 +191,7 @@
install-framebuffer:
$(Q)mkdir -p $(DESTDIR)$(NETSURF_FRAMEBUFFER_BIN)
@@ -9,8 +9,8 @@
$(Q)for F in $(NETSURF_FRAMEBUFFER_RESOURCE_LIST); do cp -vL framebuffer/res/$$F $(DESTDIR)/$(NETSURF_FRAMEBUFFER_RESOURCES); done
$(Q)$(SPLIT_MESSAGES) -l en -p fb -f messages resources/FatMessages | gzip -9n > $(DESTDIR)$(NETSURF_FRAMEBUFFER_RESOURCES)messages
---- a/netsurf/gtk/Makefile.target
-+++ b/netsurf/gtk/Makefile.target
+--- a/netsurf/frontends/gtk/Makefile.target
++++ b/netsurf/frontends/gtk/Makefile.target
@@ -142,7 +142,7 @@
install-gtk:
diff --git a/patches/libpng16-fix.patch b/patches/libpng16-fix.patch
deleted file mode 100644
index 4da88ce..0000000
--- a/patches/libpng16-fix.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-Description: use png native types, they are platform dependent.
- (and also silence some warnings about missing memcpy prototype)
-Author: Tobias Frost <tobi@debian.org>
----
-This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
---- a/netsurf/framebuffer/convert_image.c
-+++ b/netsurf/framebuffer/convert_image.c
-@@ -21,6 +21,7 @@
- #include <stdio.h>
- #include <png.h>
- #include <stdlib.h>
-+#include <string.h>
-
- #if PNG_LIBPNG_VER < 10209
- #define png_set_expand_gray_1_2_4_to_8(png) png_set_gray_1_2_4_to_8(png)
-@@ -219,7 +220,7 @@
- {
- int bit_depth, color_type, interlace, intent;
- double gamma;
-- unsigned long width, height;
-+ png_uint_32 width, height;
-
- /* Read the PNG details */
- png_get_IHDR(png, info, &width, &height, &bit_depth,
diff --git a/patches/series b/patches/series
index c649698..3ba4a07 100644
--- a/patches/series
+++ b/patches/series
@@ -1,3 +1,2 @@
set-netsurf-config.patch
change-install-binary-targets
-libpng16-fix.patch