summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSteven G. Johnson <stevenj@mit.edu>2015-03-09 22:40:51 -0400
committerSteven G. Johnson <stevenj@mit.edu>2015-03-09 22:40:51 -0400
commit08f101a9e8c6a72dfdb1c9b913df880e13a36333 (patch)
treec41b2b235ec82be729b434092bd2faeb2724014f /CMakeLists.txt
parent50381b951a2b156c1c236c77d34ac0fddbc0ea46 (diff)
parent263421f9e89aafd8ad339c496c9fb6c6bdd5a52f (diff)
downloadlibutf8proc-08f101a9e8c6a72dfdb1c9b913df880e13a36333.tar.gz
libutf8proc-08f101a9e8c6a72dfdb1c9b913df880e13a36333.tar.bz2
Merge pull request #28 from tkelman/tk/cmake
WIP: Minimal cmake build script
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt31
1 files changed, 31 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 0000000..da6aa78
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,31 @@
+cmake_minimum_required (VERSION 2.8)
+
+include (utils.cmake)
+
+disallow_intree_builds()
+
+project (utf8proc C)
+
+# Be sure to also update these in Makefile!
+set(SO_MAJOR 1)
+set(SO_MINOR 2)
+set(SO_PATCH 0)
+
+add_definitions (
+ -DUTF8PROC_EXPORTS
+)
+
+if (NOT MSVC)
+ set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -O2 -std=c99 -pedantic -Wall")
+endif ()
+
+add_library (utf8proc
+ utf8proc.c
+ utf8proc.h
+)
+
+set_target_properties (utf8proc PROPERTIES
+ POSITION_INDEPENDENT_CODE ON
+ VERSION "${SO_MAJOR}.${SO_MINOR}.${SO_PATCH}"
+ SOVERSION ${SO_MAJOR}
+)