summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorpast-due <30942300+past-due@users.noreply.github.com>2018-04-29 21:37:12 -0400
committerSteven G. Johnson <stevenj@mit.edu>2018-04-29 21:37:12 -0400
commit48949bd3ebd66bb94a40f4c3fcfb26dd4bf2be2b (patch)
treea134cb98c137196dac5fc013d244a844cae75e3a /CMakeLists.txt
parentfe3f6bda1108655f1dc9356f151a1fec76517efa (diff)
downloadlibutf8proc-48949bd3ebd66bb94a40f4c3fcfb26dd4bf2be2b.tar.gz
libutf8proc-48949bd3ebd66bb94a40f4c3fcfb26dd4bf2be2b.tar.bz2
Static library support improvements (#123)
* `#define UTF8PROC_STATIC` to disable DLLEXPORT `#define UTF8PROC_STATIC` to disable DLLEXPORT * [CMake] Automatically define UTF8PROC_STATIC if BUILD_SHARED_LIBS is off * [Makefile] Support additional UTF8PROC_DEFINES, which can be used to specify flags like `-DUTF8PROC_STATIC`
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index cbc8d93..d07dee1 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -22,6 +22,13 @@ add_library (utf8proc
utf8proc.h
)
+if (BUILD_SHARED_LIBS)
+ # Building shared library
+else()
+ # Building static library
+ target_compile_definitions(utf8proc PUBLIC "UTF8PROC_STATIC")
+endif()
+
target_compile_definitions(utf8proc PRIVATE "UTF8PROC_EXPORTS")
set_target_properties (utf8proc PROPERTIES