summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index cbc8d93..d07dee1 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -22,6 +22,13 @@ add_library (utf8proc
utf8proc.h
)
+if (BUILD_SHARED_LIBS)
+ # Building shared library
+else()
+ # Building static library
+ target_compile_definitions(utf8proc PUBLIC "UTF8PROC_STATIC")
+endif()
+
target_compile_definitions(utf8proc PRIVATE "UTF8PROC_EXPORTS")
set_target_properties (utf8proc PROPERTIES